Pages: [1] 2 3 4 5
Tags: SE1 WEBAPP APPEARS BIN CGI DOIN TOPOST URL
  Author: Topic: Cant install WebAPP Version 1.0 SE1
offline southerns
Last Visit: 02/08/10

Level 2
Joined: 03/30/08
Forum Posts: 33
 Cant install WebAPP Version 1.0 SE1
 Posted on: 05/16/08 at 08:22:42

I am trying to install WebAPP Version 1.0 SE1.

Upgraded my server and I am doin a new installation,
I used to use an older version on my old server.

At first it told me the directory did not exist (http://www.******.***/cgi-bin/install/setup.cgi)

Now it sees the install directory, but nothing appears to happen

I can send you the url, but don,t wont topost it in the open.



Shane
NetJunkie Extraordinaire
Logged
     
offline On
Last Visit: 04/18/13

Administrator
Dev
Joined: 06/19/03
Forum Posts: 5018
 Re: Cant install WebAPP Version 1.0 SE1
 Posted on: 05/16/08 at 11:06:07


southerns sa Today, 2 hours and 35 minutes ago.:
I am trying to install WebAPP Version 1.0 SE1.

Upgraded my server and I am doin a new installation,
I used to use an older version on my old server.

At first it told me the directory did not exist (http://www.******.***/cgi-bin/install/setup.cgi)

Now it sees the install directory, but nothing appears to happen

I can send you the url, but don,t wont topost it in the open.



Please note that unlike the old WebAPP Versions, WebAPP 1.0 is self extracting and requires that you start the install specifically at the html folder where you expect the site to be installed, thus you can not start the install in /install/setup.cgi

Hi!

To help you we need more information:
1.) Is this a subfolder or main site install?
2.) Have you tried tuning the form field at start of install? It supposed to point at the url path to your setup.cgi file.
3.) Server type, webhosting.
4.) Do you have a seperated locations for cgi or can you run both html and cgi files everywhere.
5.) If you have errors, it is important for us to know, how far you got with the install and where exactly you got stack, and then what the install.log show.
6.) If you got as far as extracting the cgi-bin.zip file, you would be able to use the install/test.cgi for fetching more information about your server (eg. point 4).

On



[user:On]
on@web-app.net

GC/CS/E/H/IT/L/M/MU/PA/P/S/SS/TW/O d(+++)>+ s: a+>++>+++$ C++++$ UBAHS*++++$ P+++++(--)$ L !E? W+>++ N+++@ K+++>++++++@ w$ !O M->+ V--() PS+(-) PE(++) Y+ PGP->+ t+() 5 X? R>* tv@ b++>+++ DI+++ D? G(-) e++>+++@ h----() r+++ y++++ (Words of wisdom from Larry Wall, 1993)
Logged
       
offline southerns
Last Visit: 02/08/10

Level 2
Joined: 03/30/08
Forum Posts: 33
 Re: Cant install WebAPP Version 1.0 SE1
 Posted on: 05/16/08 at 12:15:58


On said Today, 1 hour and 3 minutes ago.:
southerns sa Today, 2 hours and 35 minutes ago.:
I am trying to install WebAPP Version 1.0 SE1.

Upgraded my server and I am doin a new installation,
I used to use an older version on my old server.

At first it told me the directory did not exist (http://www.******.***/cgi-bin/install/setup.cgi)

Now it sees the install directory, but nothing appears to happen

I can send you the url, but don,t wont topost it in the open.

Please note that unlike the old WebAPP Versions, WebAPP 1.0 is self extracting and requires that you start the install specifically at the html folder where you expect the site to be installed, thus you can not start the install in /install/setup.cgi

Hi!

To help you we need more information:
1.) Is this a subfolder or main site install?  Main Site
2.) Have you tried tuning the form field at start of install? It supposed to point at the url path to your setup.cgi file.
3.) Server type, webhosting. CentOS 5.1 with Webmin and Virtualmin installed running Apache version 2.2.3
4.) Do you have a seperated locations for cgi or can you run both html and cgi files everywhere. I have a cgi-bin for cgi files, but it is my severe so I can do as I wish
5.) If you have errors, it is important for us to know, how far you got with the install and where exactly you got stack, and then what the install.log show.when you run the install it goes to  (http://www.******.***/cgi-bin/install/setup.cgi) and then nothing
6.) If you got as far as extracting the cgi-bin.zip file, you would be able to use the install/test.cgi for fetching more information about your server (eg. point 4).
install/test.cgi does nothing
On





Shane
NetJunkie Extraordinaire
Logged
     
offline On
Last Visit: 04/18/13

Administrator
Dev
Joined: 06/19/03
Forum Posts: 5018
 Re: Cant install WebAPP Version 1.0 SE1
 Posted on: 05/16/08 at 13:34:45

Dedicated apache server-sounds good.

Lets take  it step by step:
1.) You have unzipped the main package?
2.) Uploaded html/ folder content to your html folder?
3.) Uploaded cgi-bin/ folder content to your cgi-bin folder?
4.) chmod of cgi-bin/install/setup.cgi to 0755?
5.) started install at: http://www.mywebappsite.com... external link ? And saw the install page there?
6.) checked that the path at install field point at the correct path?
7.).....

You also named that the install is an a site which you prefer not the reveal, if so please remember to untick the "newsletter" option at the end of the install.

If you want I can install it for you, for this I would need access to cgi-bin/ and html/ folder you can email me at  info@web-app.net

On



[user:On]
on@web-app.net

GC/CS/E/H/IT/L/M/MU/PA/P/S/SS/TW/O d(+++)>+ s: a+>++>+++$ C++++$ UBAHS*++++$ P+++++(--)$ L !E? W+>++ N+++@ K+++>++++++@ w$ !O M->+ V--() PS+(-) PE(++) Y+ PGP->+ t+() 5 X? R>* tv@ b++>+++ DI+++ D? G(-) e++>+++@ h----() r+++ y++++ (Words of wisdom from Larry Wall, 1993)
Logged
       
offline southerns
Last Visit: 02/08/10

Level 2
Joined: 03/30/08
Forum Posts: 33
 Re: Cant install WebAPP Version 1.0 SE1
 Posted on: 05/16/08 at 14:29:03

I will email it to you, its just I dont want to paste the address with the install script still accessible in an open forum.

I can give you the root access to the Webmin & Vitualmin.



Shane
NetJunkie Extraordinaire
Logged
     
offline On
Last Visit: 04/18/13

Administrator
Dev
Joined: 06/19/03
Forum Posts: 5018
 Re: Cant install WebAPP Version 1.0 SE1
 Posted on: 05/16/08 at 14:34:02


southerns said 2 minutes and 18 seconds ago.:
I will email it to you, its just I dont want to paste the address with the install script still accessible in an open forum.

I can give you the root access to the Webmin & Vitualmin.



Concerning the install script scurity, once it is triggered, no one except the person whom triggered it can access it, it is protected by a "one user only cookie". Either way I agree with you it is not wise to post in public the address before the site is fully installed. Will install it tonight.

On



[user:On]
on@web-app.net

GC/CS/E/H/IT/L/M/MU/PA/P/S/SS/TW/O d(+++)>+ s: a+>++>+++$ C++++$ UBAHS*++++$ P+++++(--)$ L !E? W+>++ N+++@ K+++>++++++@ w$ !O M->+ V--() PS+(-) PE(++) Y+ PGP->+ t+() 5 X? R>* tv@ b++>+++ DI+++ D? G(-) e++>+++@ h----() r+++ y++++ (Words of wisdom from Larry Wall, 1993)
Logged
       
offline southerns
Last Visit: 02/08/10

Level 2
Joined: 03/30/08
Forum Posts: 33
 Re: Cant install WebAPP Version 1.0 SE1
 Posted on: 05/16/08 at 15:47:58

Thanx.

I have sent it hope you received it.



Shane
NetJunkie Extraordinaire
Logged
     
offline On
Last Visit: 04/18/13

Administrator
Dev
Joined: 06/19/03
Forum Posts: 5018
 Re: Cant install WebAPP Version 1.0 SE1
 Posted on: 05/16/08 at 19:56:21


southerns sa Today, 4 hours and 5 minutes ago.:
Thanx.

I have sent it hope you received it.



Hi,

I got your email, tried to ftp and got errors (sent you an email with the errors), should I try to SSH?

On



[user:On]
on@web-app.net

GC/CS/E/H/IT/L/M/MU/PA/P/S/SS/TW/O d(+++)>+ s: a+>++>+++$ C++++$ UBAHS*++++$ P+++++(--)$ L !E? W+>++ N+++@ K+++>++++++@ w$ !O M->+ V--() PS+(-) PE(++) Y+ PGP->+ t+() 5 X? R>* tv@ b++>+++ DI+++ D? G(-) e++>+++@ h----() r+++ y++++ (Words of wisdom from Larry Wall, 1993)
Logged
       
offline On
Last Visit: 04/18/13

Administrator
Dev
Joined: 06/19/03
Forum Posts: 5018
 Re: Cant install WebAPP Version 1.0 SE1
 Posted on: 05/16/08 at 20:04:24

Ops, never mind. SSH works fine. Will start working on it now.

On



[user:On]
on@web-app.net

GC/CS/E/H/IT/L/M/MU/PA/P/S/SS/TW/O d(+++)>+ s: a+>++>+++$ C++++$ UBAHS*++++$ P+++++(--)$ L !E? W+>++ N+++@ K+++>++++++@ w$ !O M->+ V--() PS+(-) PE(++) Y+ PGP->+ t+() 5 X? R>* tv@ b++>+++ DI+++ D? G(-) e++>+++@ h----() r+++ y++++ (Words of wisdom from Larry Wall, 1993)
Logged
       
offline southerns
Last Visit: 02/08/10

Level 2
Joined: 03/30/08
Forum Posts: 33
 Re: Cant install WebAPP Version 1.0 SE1
 Posted on: 05/16/08 at 20:38:25

Thanx will pop in later again



Shane
NetJunkie Extraordinaire
Logged
     
offline On
Last Visit: 04/18/13

Administrator
Dev
Joined: 06/19/03
Forum Posts: 5018
 Re: Cant install WebAPP Version 1.0 SE1
 Posted on: 05/16/08 at 20:48:23


southerns said 7 minutes and 7 seconds ago.:
Thanx will pop in later again



I did a small test: see "hello" (yours) and "hello2" (mine) they are identical but only yours work, which means...

You need to configure suEXEC: http://httpd.apache.org... external link
I hope it makes sense to you.

On



[user:On]
on@web-app.net

GC/CS/E/H/IT/L/M/MU/PA/P/S/SS/TW/O d(+++)>+ s: a+>++>+++$ C++++$ UBAHS*++++$ P+++++(--)$ L !E? W+>++ N+++@ K+++>++++++@ w$ !O M->+ V--() PS+(-) PE(++) Y+ PGP->+ t+() 5 X? R>* tv@ b++>+++ DI+++ D? G(-) e++>+++@ h----() r+++ y++++ (Words of wisdom from Larry Wall, 1993)
Logged
       
offline southerns
Last Visit: 02/08/10

Level 2
Joined: 03/30/08
Forum Posts: 33
 Re: Cant install WebAPP Version 1.0 SE1
 Posted on: 05/16/08 at 22:58:44

Thanx for th help.

You have lost me here,
But i have contacted my Servers Technical guys to see what they say.



Shane
NetJunkie Extraordinaire
Logged
     
offline On
Last Visit: 04/18/13

Administrator
Dev
Joined: 06/19/03
Forum Posts: 5018
 Re: Cant install WebAPP Version 1.0 SE1
 Posted on: 05/16/08 at 23:52:36

This should give them a clue:
They need to set the Perl script permission correctly for ALL Perl just like the hello.cgi is set. By doing something like:
user->suid root->all other users...........

Unless of course you want only the root to access the *.cgi in your site. Either way, its best to let someone who knows suEXEC well to mess with it smile.

Otherwise, both cgi and html  paths seems to work perfectly fine from your html/ folder.[left][/left]



[user:On]
on@web-app.net

GC/CS/E/H/IT/L/M/MU/PA/P/S/SS/TW/O d(+++)>+ s: a+>++>+++$ C++++$ UBAHS*++++$ P+++++(--)$ L !E? W+>++ N+++@ K+++>++++++@ w$ !O M->+ V--() PS+(-) PE(++) Y+ PGP->+ t+() 5 X? R>* tv@ b++>+++ DI+++ D? G(-) e++>+++@ h----() r+++ y++++ (Words of wisdom from Larry Wall, 1993)
Logged
       
offline southerns
Last Visit: 02/08/10

Level 2
Joined: 03/30/08
Forum Posts: 33
 Re: Cant install WebAPP Version 1.0 SE1
 Posted on: 05/17/08 at 00:22:23

Thanx I have passed on the message and am waiting on their response.



Shane
NetJunkie Extraordinaire
Logged
     
offline southerns
Last Visit: 02/08/10

Level 2
Joined: 03/30/08
Forum Posts: 33
 Re: Cant install WebAPP Version 1.0 SE1
 Posted on: 05/17/08 at 01:34:09

I have set the setup.cgi owner to the same as hello.cgi.

is there any others that need to be changed.



Shane
NetJunkie Extraordinaire
Logged
     
offline On
Last Visit: 04/18/13

Administrator
Dev
Joined: 06/19/03
Forum Posts: 5018
 Re: Cant install WebAPP Version 1.0 SE1
 Posted on: 05/17/08 at 03:34:42


southerns said Today, 1 hour and 58 minutes ago.:
I have set the setup.cgi owner to the same as hello.cgi.

is there any others that need to be changed.



Yes, ALL the Perl scripts.



[user:On]
on@web-app.net

GC/CS/E/H/IT/L/M/MU/PA/P/S/SS/TW/O d(+++)>+ s: a+>++>+++$ C++++$ UBAHS*++++$ P+++++(--)$ L !E? W+>++ N+++@ K+++>++++++@ w$ !O M->+ V--() PS+(-) PE(++) Y+ PGP->+ t+() 5 X? R>* tv@ b++>+++ DI+++ D? G(-) e++>+++@ h----() r+++ y++++ (Words of wisdom from Larry Wall, 1993)
Logged
       

  Cant install WebAPP Version 1.0 SE1
  Support
  Forums
  
Pages: [1] 2 3 4 5
Hop to: