Pages: [1]
  Author: Topic: On what does this run ?
offline blabit
Last Visit: 11/17/15

Level 1
Joined: 11/14/15
Forum Posts: 1
 On what does this run ?
 Posted on: 11/17/15 at 02:51:33

Hello for a few weeks I have been trying to install this on a bare linux system. I do know my way around enough to get the new stuff going. ( Centos servers etc ) I know how to run the shell and know where most common configuration files are etc...

The few simple cgi scripts I ever ran worked fine from the web directory cgi-bin. I always install my linux server using the server installs. I think this is how we are supposed to do this?

Anyhow no matter what linux I try. Centos debian or Ubuntu all from default LAMP stack. The install from this script simply fails. Like I have read on these forums I get the internal server error when I got to cgi-bin/setup.cgi

when I delete the file from the cgi directory and call it again from a web browser I get file not found error instead. That is a good sign. My paths are correct. Since I run all my boxes here at home on real but old computers just to try and  get this script to run I change all files and folders to 777 and still no change.

And I did make sure that my path to perl is ok everytime. Lucky for me it seems to be mostly a default value that does not change much from one linux to another :)

My next step I figured was to downgrade. I tried installing old Linux os from about 2003 from Redhat 7 and upwards til today.Fedora Centos Debian you name it I probalby tried it!  Again with every single install. I dont know what I am missing or what I am not selection? It seems to me that for this script to work we need to change some basic configurations. In other words I may be wrong but it seems this script does not run out of the box on an average linux fresh install. even with pre configured LAMP stack with cgi and perl from the server oriented distributions.

So here is my question. Could you be so kind and save me all the troubles of trying to guess what I need and give me an idea of what I need?

What Linux version are you running this script on ? Like very specific since I'm a little slow lol. Like what configurations did you use during a setup that worked? What system configs have you had to change to make this work?

I looked everywhere on this site and can't find that information. Usually a script has a page section in details describing exactly what server linux version down to what dependencies are needed. and tweaks and mods that need to be done to the OS in prior to getting the script installed.  Maybe it is because my questions to the casual perl user are just obvious and not mentioned but since I never really played with perl I really don't know what I have to change on the server end to make this script fly :(

The reason I want this is to break away from PHP and MYSQL. These systems tie up much of my needed resources, I just want a small site for a hobby self hosted without having to pay for it since I don't have that much money and since I am not a linux IT expert as soon as I run any complex PHP CMS scripts, I have a nak for getting hacked. But I never had these issues with just cgi and html sites from when I remember being a teen. Now if only I knew what I did/was the standard at the time to make them work!

Any info would be great!
Thank you so much great script btw just what I am looking for.


I was able to get to the setup page of the script by modifying every .cgi file to reflect #!/usr/bin/perl -w instead. I am not sure why the -w at the end makes the script load. Even with the whole web directory and subs and files set to CHMOD 777. The install complaints that It can not set permissions but still say >>> Configuration Updated!!!. Now going to http://mydomian... external link gives a new error as such in the web browser:

Can't modify constant item in lock at /home/mydomain/public_html/cgi-bin/cgi-lib/ line 459, near "LOG)"
Compilation failed in require at /home/mydomain/public_html/cgi-bin/index.cgi line 32.

If this problem persits, please contact the webmaster and inform him about date and time you've recieved this error.
SD: /home/mydomain/public_html/cgi-bin

Anyone?? This script must work almost out of the box with the proper linux server configurations! :) Please if someone can just take a moment to be nice and guide me in the right direction for example mention what version of linux you installed and what you had to do to make it work :)

I do not want to have to pay for a hosting server that has everything already setup. I am my hosting server. This is just a small hobby home project self hosted. Thanks!

My generic signature...
offline Jack Deth
Last Visit: 01/09/18

Joined: 02/13/05
Forum Posts: 3724
 Re: On what does this run ?
 Posted on: 12/15/15 at 22:34:02

I have used WebAPP since version 0.2 and they all loaded fine for me…

the lock error was something that happened when they updated perl years ago…  it was all fixed in versions of
web-app since then…

not sure why your configuration isn't working… but this script runs on 98% of all simple basic server setups…

without seeing more there is no way to troubleshoot your situation...

Beta-Tester Extraordinaire.

Testing on various platforms and operating systems... external link external link
offline SafePit
Last Visit: 02/22/18

Joined: 11/03/06
Forum Posts: 494
 Re: On what does this run ?
 Posted on: 03/28/16 at 05:00:32

I know this is old but just got around to installing V1 as a test and ran into the same issue.
Seems the setup.cgi is defined with Windows style newlines which will generate a 500
error internally.  Running a 'file' command on the setup.cgi script shows an odd character
after the name (perl will run it just fine, just Apache doesn't like it).

Even though I used "unzip -a" it still didn't fix the file. I manually converted the newlines
(pick your favorite method) and things started to work. Didn't seem to have any issues
with the compressed scrips (they all worked fine).

P.S. Tried to do an upgrade and it kind of sort of didn't work. First problem was the theme
wasn't reset (since all the old themes are moved) causing a 500 error. Fixed that in the
config, but couldn't login (again 500 error). Not overly concerned since I had heavily
modified my site so I expect that it is something that I did, but the theme is a bit of a

As a side note, there are a bunch of default options that might make sense for this site,
but don't work well for first time installers—things like AdSense set with a default
account, banners turned on, email spam, themes listed that aren't part of the installation,

P.P.S. Is the latest download actually patched? Seems not. We should fix that as well.

Got a WebAPP site?  Show it off!


  On what does this run ?
Pages: [1]
Hop to: